Alcatel-Lucent Virtualized Simulator on GNS3

The Alcatel-Lucent virtualized Simulator (vSim) is a virtualization-ready version of SR OS called SR OS-VM. This new operating system is designed to run in a virtual machine (VM) on a generic Intel x86 server. In control and management plane aspects, the vSim is functionally and operationally equivalent to an Alcatel-Lucent hardware-based SR OS router.The vSim is intended to be used as a laboratory tool to fully simulate the control and management plane of an SR OS node. The vSim is not intended to be used in a production network environment and the forwarding plane is limited to 250 pps per interface. Furthermore, without a license file it will run for 1 hour before reloading.

Host Software and Hardware Requirements

  • Linux x86-64
  • Qemu emulator version 2.8.0 (qemu-system-x86_64 or i386)
  • GNS3 version 1.5. or later
  • RAM - at least 4 GB
  • CPU with hardware virtualization support (VT-x or AMD-V)

Virtual Machines Software and Hardware Requirements

  • TiMOS-B-13.0.R4 both/i386 ALCATEL SR 7750
  • RAM 2048 MB, CPU x86-32
  • Qemu additional parameters: -nographic -enable-kvm

1. Installation Steps

Extract image from the zip file.

$ unzip TiMOS-SR-13.0.R4-vm.zip

Now a virtual disk sros-vm.qcow2 is extracted. To start Qemu virtual machine use the command:

$ /usr/local/bin/qemu-system-x86_64 -m 2048MB -enable-kvm alcatel-sros-vm-13.0.R4.qcow2
-serial  telnet:localhost:3366,server,nowait -smp 2

Telnet to a serial port of virtual machine with the command:

$ telnet localhost 3366

Login with username admin and password admin.

Check  cards that are presented presented in a system with the command:

A:vRR# show card state

Picture1-Timos_Cards

Picture 1 - Card iom3-xp-b is Detected but not Provisioned

Card IOM3-XP-B is equipped in slot 1 of chasis but it is not provisioned. Thus we mustto provision it for the slot 1.

*A:vRR# configure card 1 card-type "iom3-xp-b"

Picture2-Provisioned_iom3-xp-b_Card

Picture 2 - Card iom3-xp-b Provisioned in Slot 1

Card iom3-xp-b accepts up to two Media Dependent Adapters (MDAs). There is a one unprovisioned module m5-1gb-sfp-b equipped in port one of card iom3-xp-b that provides five Ethernet interfaces.   We have to specify slot and mda type and save configuration.

*A:vRR# configure card 1 mda 1 mda-type "m5-1gb-sfp-b"
*A:vRR# admin save

Now we can connect vSIM virtual machine to connect to GNS3.

2. Connecting vSIM to GNS3

We are going to create a simple topology in order to check network connectivity between vSIM ports and Core Linux hosts.

Picture3-Testing_Topology

Picture 3 - Port Connectivity Testing Topology

They are six Linux Core hosts connected to the ports of virtual service router. A table mapping vSIM ports and how they are presented in TiMOS configuration is following:

Timos ----- vSIM ports
bof ----------- eth0
1/1/1 --------- eth1
1/1/2 --------- eth2
1/1/3 --------- eth3
1/1/4 --------- eth4
1/1/5 --------- eth5

2.1 Configure GNS3 Qemu VMs Preferences

Navigate to Edit -> Preferences -> QEMU VMs and configure VM parameters according to the picture below.

Picture 4 - GNS3 Qemu VM Configuration

2.2 IP Address Configuration  for Control Proccessor Module (CPM) Management Ethernet Interface

The interface eth0 is connected to CPM management interface. Use BOF command-line interface (CLI) to configure IP address for CPM interface.

*A:vRR# bof address 10.10.10.1/24

Save bof configuration.
*A:vRR# bof save

To ping an IP address of the host connected to a management interface of vSIM issue the command:

*A:vRR# ping 10.10.10.2 router "management"

The config file of vSIM router can be displayed with the command:

*A:vRR# admin display-config

2.3 Linux Core Configuration - PC0

Login with username tc. Password is not set.

tc@box:~$ sudo su
root@box:~# echo "ifconfig eth0 10.10.10.2 netmask 255.255.255.0" >> /opt/bootlocal.sh
root@box:~# echo "route add default gw 10.10.10.1" >> /opt/bootlocal.sh
root@box:~# /opt/bootlocal.sh
root@box:~# /usr/bin/filetool.sh -b

2.4 IP Address Configuration  for  Port 1/1/1

*A:vRR# configure port 1/1/1 no shutdown
*A:vRR# configure router interface "PC1" address 192.168.1.1/24
*A:vRR# configure router interface "PC1" port 1/1/1

Note: The interface Ethernet 1 is represented by the port 1/1/1 in TiMOS configuration.

2.5 Linux Core Configuration - PC1

tc@box:~$ sudo su
root@box:~# echo "ifconfig eth0 192.168.1.2 netmask 255.255.255.0" >> /opt/bootlocal.sh
root@box:~# echo "route add default gw 192.168.1.1" >> /opt/bootlocal.sh
root@box:~# /opt/bootlocal.sh
root@box:~# /usr/bin/filetool.sh -b

2.6 IP Address Configuration  for  Port 1/1/2

*A:vRR# configure port 1/1/2 no shutdown
*A:vRR# configure router interface "PC2" address 192.168.2.1/24
*A:vRR# configure router interface "PC2" port 1/1/2

2.7 Linux Core Configuration - PC2

tc@box:~$ sudo su
root@box:~# echo "ifconfig eth0 192.168.2.2 netmask 255.255.255.0" >> /opt/bootlocal.sh
root@box:~# echo "route add default gw 192.168.2.1" >> /opt/bootlocal.sh
root@box:~# /opt/bootlocal.sh
root@box:~# /usr/bin/filetool.sh -b

2.8. IP Address Configuration  for  Port 1/1/3

*A:vRR# configure port 1/1/3 no shutdown
*A:vRR# configure router interface "PC3" address 192.168.3.1/24
*A:vRR# configure router interface "PC3" port 1/1/3

2.9 Linux Core Configuration - PC3

tc@box:~$ sudo su
root@box:~# echo "ifconfig eth0 192.168.3.2 netmask 255.255.255.0" >> /opt/bootlocal.sh
root@box:~# echo "route add default gw 192.168.3.1" >> /opt/bootlocal.sh
root@box:~# /opt/bootlocal.sh
root@box:~# /usr/bin/filetool.sh -b

2.10 IP Address Configuration  for  Port 1/1/4

*A:vRR# configure port 1/1/4 no shutdown
*A:vRR# configure router interface "PC4" address 192.168.4.1/24
*A:vRR# configure router interface "PC4" port 1/1/4

2.11 Linux Core Configuration - PC4

tc@box:~$ sudo su
root@box:~# echo "ifconfig eth0 192.168.4.2 netmask 255.255.255.0" >> /opt/bootlocal.sh
root@box:~# echo "route add default gw 192.168.4.1" >> /opt/bootlocal.sh
root@box:~# /opt/bootlocal.sh
root@box:~# /usr/bin/filetool.sh -b

2.12 IP Address Configuration  for  Port 1/1/5

*A:vRR# configure port 1/1/5 no shutdown
*A:vRR# configure router interface "PC5" address 192.168.5.1/24
*A:vRR# configure router interface "PC5" port 1/1/5

2.13 Linux Core Configuration - PC5

tc@box:~$ sudo su
root@box:~# echo "ifconfig eth0 192.168.5.2 netmask 255.255.255.0" >> /opt/bootlocal.sh
root@box:~# echo "route add default gw 192.168.5.1" >> /opt/bootlocal.sh
root@box:~# /opt/bootlocal.sh
root@box:~# /usr/bin/filetool.sh -b

2.14 Additional Configuration

Hostname
A:vRR# configure system name Timos-I

Admin Password
*A:Timos-I#password

Save Configuration
*A:Timos-I# admin save

2.15 Testing Connectivity between vSIM Ports

Login to PC1 and ping IP address of PC2, PC3, PC4 and PC5. As the hosts have default gateway configured, ping should be successful.

Picture5_Testing_COnnectivity_Between_vSIM_Ports

Picture 5 - Testing Connectivity Between vSIM Ports

3. Testing OSPF MD5 Authentication Between Cisco CSR1000v and Alcatel-Lucent vSIM

In this lab we will focus on configuration and testing authentication in OSPF routing protocol running on Cisco CSR1000v router and Alcatel-Lucent virtual simulator.

Installation and configuration  of Cisco Cloud Service Router CSR1000v in GNS3 is explained here.

Picture6-OSPF_Testing_Topoly

Picture 6 - OSPF Authentication Testing Topology

Note: A Link labeled as eth0 and connected to the first available port on CSR1000v is presented as interface GigabitEthernet 1 in CSR1000v configuration. Similarly, a link labeled as eth1 and connected to the second available port on Alcatel-Lucent vSIM is presented as port 1/1/1 in TiMOS CLI.

3.1 OSPF Configuration on CSR1000v

Password is set to lab123 and it must match between two OSPF neighbors.

Router>enable
Router#conf t

Router(config)#interface gigabitEthernet 1
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#ip ospf network point-to-point
Router(config-if)#ip ospf authentication message-digest
Router(config-if)#ip ospf message-digest-key 1 md5 lab123
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#hostname CSR1000v-I
CSR1000v-I(config)#ip routing

SR1000v-I(config)#interface loopback 0
CSR1000v-I(config-if)#ip address 10.10.10.1 255.255.255.252
CSR1000v-I(config-if)#no shutdown

CSR1000v-I(config)#router ospf 1
CSR1000v-I(config-router)#router-id 1.1.1.1
CSR1000v-I(config-router)#network 10.10.10.2 0.0.0.0 area 0
CSR1000v-I(config-router)#network 192.168.1.0 0.0.0.3 area 0

Note: If you want to enable MD5 authentication for all interfaces in area 0, add the command:

CSR1000v-I(config-router)#area 0 authentication message-digest

3.2 OSPF Configuration Alcatel-Lucent Virtual Simulator

*A:vRR#configure system name Timos-I
*A:Timos-I# configure port 1/1/1 no shutdown
*A:Timos-I# configure router interface toCSR address 192.168.1.2/30
*A:Timos-I# configure router interface "toCSR" port 1/1/1
*A:Timos-I# configure router interface lo0 address 10.10.10.2/30
*A:Timos-I# configure router interface "lo0" loopback

*A:Timos-I# configure router ospf router-id 2.2.2.2
*A:Timos-I# configure router ospf area 0.0.0.0 interface "toCSR" interface-type point-to-point
*A:Timos-I# configure router ospf area 0.0.0.0 interface "lo0"

A:Timos-I# configure router ospf area 0.0.0.0 interface "toCSR" authentication-type message-digest
*A:Timos-I# configure router ospf area 0.0.0.0 interface "toCSR" message-digest-key 1 md5 "lab123"

Note: vSIM has the maximum transmission unit (MTU) set to 8936 Bytes for Ethernet interfaces by default. The default MTU value for CSR 1000v  Ethernet interfaces is 1500 Bytes. In order to establish OSPF neigborship between two routers, MTU must match on both sides of link. For this reason we must configure MTU 1500 Bytes for vSIM port 1/1/1.

However as it is shown from the debug command enabled on Cisco, CSR 1000v continues complaining about smaller size of MTU. The MTU received in OSPF packets from the neighbor vSIM router is 1486 Bytes. It causes that routers are not fully adjacent and they stay in EXCHANGE neighbor state.

CSR1000v-I#debug ip ospf adj
*Dec 16 19:17:24.428: OSPF-1 ADJ Gi1: Rcv DBD from 2.2.2.2 seq 0x1E opt 0x42 flag 0x7 len 32 mtu 1486 state EXCHANGE
*Dec 16 19:17:24.428: OSPF-1 ADJ Gi1: Nbr 2.2.2.2 has smaller interface MTU

Changing MTU parameter to 1514 Bytes for Ethernet port 1/1/1 on vSIM  helps to solve the issue.

*A:Timos-I# configure port 1/1/1 ethernet mtu 1514

3.3 OSPF MD5 Authentication Trobleshooting

We are going to check if routers are fully adjacent and if OSPF routes are presented in both routers's routing tables.

3.3.1 Checking OSPF on CSR1000v

CSR1000v-I#show ip ospf neighbor

Picture7-OSPF_Neigborship_Cisco

Picture 7 - Full OSPF Neigborship Established

CSR1000v-I#show ip route

Picture8_CSR1000v_Routing_Table

Picture 8 - Routing Table of Cisco CSR1000v

3.3.2 Checking OSPF on Alcatel-Lucent vSIM

A:Timos-I# show router ospf

Picture9-OSPF_Neigborship_vSIM

Picture9 - OSPF Neighbor 1.1.1.1 presented in TiMOS CLI

A:Timos-I# show router route-table

Picture10_vSIM_Routing_Table

Picture 10 - Routing Table of Alcatel-Lucent vSIM

End.

References:
http://echorequest.info/
http://labelswitched.blogspot.sk/2013/02/understanding-alcatel-lucent-ipv4.html
http://labelswitched.blogspot.sk/2013/02/ospf-configuration-comparison.html

 

32 thoughts on “Alcatel-Lucent Virtualized Simulator on GNS3

  1. i have simulated alcatel in gns3 in a different manner, i did not use linux as host, but i getting a problem that when alcatel router is directly connected with other router, they do not ping each other. can you tell me what is problem.
    i know that alcatel ethernet 0 is used for administrative purpose, so i connected router with ethernet 1, but still there is not ping.

    1. hopely you knew already the issue, you have to stop router and delete the link and re-create the link again and start again the router, it is same issue when you simulate ios-xr on gns3 ..

  2. A:vRR# admin display-config
    # TiMOS-B-12.0.R6 both/i386 ALCATEL SR 7750 Copyright (c) 2000-2014 Alcatel-Lucent.
    # All rights reserved. All use subject to applicable license agreements.
    # Built on Tue Sep 30 11:10:17 PDT 2014 by builder in /rel12.0/b1/R6/panos/main

    # Generated MON DEC 29 19:54:11 2014 UTC

    exit all
    configure
    #--------------------------------------------------
    echo "System Configuration"
    #--------------------------------------------------
    system
    dns
    exit
    snmp
    exit
    time
    sntp
    shutdown
    exit
    zone UTC
    exit
    thresholds
    rmon
    exit
    exit
    exit
    #--------------------------------------------------
    echo "System Security Configuration"
    #--------------------------------------------------
    system
    security
    no per-peer-queuing
    cpu-protection
    link-specific-rate max
    policy 254 create
    exit
    policy 255 create
    exit
    port-overall-rate 15000
    exit
    exit
    exit
    #--------------------------------------------------
    echo "Log Configuration"
    #--------------------------------------------------
    log
    exit
    #--------------------------------------------------
    echo "System Security Cpm Hw Filters and PKI Configuration"
    #--------------------------------------------------
    system
    security
    exit
    exit
    #--------------------------------------------------
    echo "QoS Policy Configuration"
    #--------------------------------------------------
    qos
    exit
    #--------------------------------------------------
    echo "Card Configuration"
    #--------------------------------------------------
    card 1
    card-type iom3-xp-b
    mda 1
    mda-type m5-1gb-sfp-b
    no shutdown
    exit
    no shutdown
    exit
    #--------------------------------------------------
    echo "Port Configuration"
    #--------------------------------------------------
    port 1/1/1
    ethernet
    exit
    no shutdown
    exit
    port 1/1/2
    ethernet
    exit
    no shutdown
    exit
    port 1/1/3
    ethernet
    exit
    no shutdown
    exit
    port 1/1/4
    ethernet
    exit
    no shutdown
    exit
    port 1/1/5
    ethernet
    exit
    no shutdown
    exit
    #--------------------------------------------------
    echo "System Sync-If-Timing Configuration"
    #--------------------------------------------------
    system
    sync-if-timing
    begin
    commit
    exit
    exit
    #--------------------------------------------------
    echo "Management Router Configuration"
    #--------------------------------------------------
    router management
    exit

    #--------------------------------------------------
    echo "Router (Network Side) Configuration"
    #--------------------------------------------------
    router
    interface "port1/1/1"
    address 10.0.0.1/24
    port 1/1/1
    no shutdown
    exit
    interface "system"
    no shutdown
    exit
    exit

    #--------------------------------------------------
    echo "Service Configuration"
    #--------------------------------------------------
    service
    customer 1 create
    description "Default customer"
    exit
    exit
    #--------------------------------------------------
    echo "Router (Service Side) Configuration"
    #--------------------------------------------------
    router
    #--------------------------------------------------
    echo "WLAN Gateway Configuration"
    #--------------------------------------------------
    exit

    exit all

    # Finished MON DEC 29 19:54:41 2014 UTC

    A:vRR# show mda

    ===============================================================================
    MDA Summary
    ===============================================================================
    Slot Mda Provisioned Type Admin Operational
    Equipped Type (if different) State State
    -------------------------------------------------------------------------------
    1 1 m5-1gb-sfp-b up up
    ===============================================================================
    A:vRR#
    A:vRR#
    A:vRR# show card

    ===============================================================================
    Card Summary
    ===============================================================================
    Slot Provisioned Type Admin Operational Comments
    Equipped Type (if different) State State
    -------------------------------------------------------------------------------
    1 iom3-xp-b up up
    A sfm4-12 up up/active
    B sfm4-12 up down/standby
    (not equipped)
    ===============================================================================
    A:vRR# show port

    ===============================================================================
    Ports on Slot 1
    ===============================================================================
    Port Admin Link Port Cfg Oper LAG/ Port Port Port C/QS/S/XFP/
    Id State State MTU MTU Bndl Mode Encp Type MDIMDX
    -------------------------------------------------------------------------------
    1/1/1 Up Yes Up 8936 8936 - netw null xcme GIGE-LX 10KM
    1/1/2 Up Yes Up 8936 8936 - netw null xcme GIGE-LX 10KM
    1/1/3 Up Yes Up 8936 8936 - netw null xcme GIGE-LX 10KM
    1/1/4 Up Yes Up 8936 8936 - netw null xcme GIGE-LX 10KM
    1/1/5 Up Yes Up 8936 8936 - netw null xcme GIGE-LX 10KM

    ===============================================================================
    Ports on Slot A
    ===============================================================================
    Port Admin Link Port Cfg Oper LAG/ Port Port Port C/QS/S/XFP/
    Id State State MTU MTU Bndl Mode Encp Type MDIMDX
    -------------------------------------------------------------------------------
    A/1 Up Yes Up 1514 1514 - netw null faste MDI

    ===============================================================================

    1. no brother it did not work, same problem cant ping from one side to other, i checked the packets in wireshark but nothing is there

  3. Hello guys,

    I did this simulation in a Windows 7 laptop, VM started and is working ok. The only problem I am facing right now is that when I stop and start again the VM the configuration file was in 0 bytes so VM start with no configuration.
    Have you seen same behavior?
    If so, is there any way to solve this problem?
    I am using i386 version of qemu

    Thanks is advance for your help!

    Here some outputs:

    1- Config File output before saving config:

    *A:SR-1>file cf3:\ # dir

    Volume in drive cf3 on slot A is SROS VM.
    Volume in drive cf3 on slot A is formatted as FAT32

    Directory of cf3:\

    01/24/2015 01:44p .ssh/
    09/30/2014 11:11a 191 bof.cfg
    09/30/2014 11:11a 0 config.cfg <<<<<<
    09/30/2014 11:11a 95 nvram.dat
    01/24/2015 01:43p 317 nvsys.info
    01/24/2015 01:43p 1 restcntr.txt
    09/30/2014 11:11a syslinux/
    09/30/2014 11:11a timos/
    5 File(s) 604 bytes.
    3 Dir(s) 403316736 bytes free.

    *A:SR-1>file cf3:\ # exit

    2 - Applying SAVE command:

    *A:SR-1# admin save
    Writing configuration to cf3:\config.cfg
    Saving configuration ... OK
    Completed.
    A:SR-1#
    A:SR-1# file
    A:SR-1>file cf3:\ # dir

    Volume in drive cf3 on slot A is SROS VM.
    Volume in drive cf3 on slot A is formatted as FAT32

    Directory of cf3:\

    01/24/2015 01:44p .ssh/
    09/30/2014 11:11a 191 bof.cfg
    01/24/2015 01:52p 4108 config.cfg <<<<<<<< greater than zero!
    09/30/2014 11:11a 0 config.cfg.1
    09/30/2014 11:11a 95 nvram.dat
    01/24/2015 01:43p 317 nvsys.info
    01/24/2015 01:43p 1 restcntr.txt
    09/30/2014 11:11a syslinux/
    09/30/2014 11:11a timos/
    6 File(s) 4712 bytes.
    3 Dir(s) 403308544 bytes free.

    A:SR-1>file cf3:\ #

    3- Log after STOP and START VM

    Rebooting...
    Doing hard reboot...
    Enabled core count: 1
    Running in a UNKNOWN virtual machine

    Total Memory: 1536MB Chassis Type: unknown
    TiMOS-V-12.0.R6 bootrom/i386 ALCATEL ? 7xxx Copyright (c) 2000-2014 Alcatel-Lucent.
    All rights reserved. All use subject to applicable license agreements.
    Built on Tue Sep 30 11:09:02 PDT 2014 by builder in /rel12.0/b1/R6/panos/main
    Looking for boot parameters.

    workQPanic: Kernel work queue overflow.

    Press any key to stop auto-boot...
    0
    auto-booting...

    boot device : ata=0,2
    unit number : 0
    processor number : 0
    host name : 0.0.0.0
    file name : cf3:/timos/boot.tim
    ftp password (pw) : *****
    flags (f) : 0x8
    target name (tn) : vRR
    startup script (s) : pl=1
    other (o) : sr12#niente_a_r2_6f,lava_r3|22|0

    Booting from ata=0,2:cf3:/timos/boot.tim
    Loading cf3:/timos/boot.tim ...
    Version L-12.0.R6, Tue Sep 30 11:09:39 PDT 2014 by builder in /rel12.0/b1/R6/panos/main
    text:(1649920-->3819948) + data:(120896-->522452)
    Starting at 0x18000000...

    (s) boot params: pl=1; setting TgtPf to 0x00000001

    ACPI: ctrl-x only supported with PXE boot. (version >= 3)

    Enabled core count: 1
    emGetMacAddr: unit 0 is not VALID

    Running in a UNKNOWN virtual machine

    Total Memory: 1536MB Chassis Type: sr12 Core Freq: 2598.301 MHz
    TiMOS-L-12.0.R6 boot/i386 ALCATEL SR 7750 Copyright (c) 2000-2014 Alcatel-Lucent.
    All rights reserved. All use subject to applicable license agreements.
    Built on Tue Sep 30 11:09:39 PDT 2014 by builder in /rel12.0/b1/R6/panos/main

    TiMOS BOOT LOADER
    platformVmRestrict: unsupported hypervisor: UNKNOWN (3)
    platformVmRestrict: unsupported apic mode (0)

    Time from clock is SAT JAN 24 13:42:20 2015 UTC
    Switching serial output to sync mode... done

    Looking for cf3:/bof.cfg ... OK, reading

    Contents of Boot Options File on cf3:
    primary-image cf3:\timos\both.tim
    primary-config cf3:\config.cfg
    autonegotiate
    duplex full
    speed 100
    wait 3
    persist off
    no li-local-save
    no li-separate
    console-speed 115200

    Hit a key within 1 second to change boot parameters...
    No license file specified

    Primary image location: cf3:\timos\both.tim
    Loading image cf3:\timos\both.tim
    Version B-12.0.R6, Tue Sep 30 11:10:17 PDT 2014 by builder in /rel12.0/b1/R6/panos/main
    text:(46273376-->131588524) + data:(7236736-->33066188)
    Executing TiMOS image at 0x12A000

    Enabled core count: 1

    Running in a UNKNOWN virtual machine

    ######################################################################
    # WARNING: Simulating a multi-core board on a single core simulator. #
    # Some features may behave differently than when simulated #
    # on a multicore sim. #
    # SMP is not being simulated. #
    # Not able to run 64-bit architecture. #
    ######################################################################

    Total Memory: 1919MB Chassis Type: sr12 Core Freq: 2594.127 MHz
    TiMOS-B-12.0.R6 both/i386 ALCATEL SR 7750 Copyright (c) 2000-2014 Alcatel-Lucent.
    All rights reserved. All use subject to applicable license agreements.
    Built on Tue Sep 30 11:10:17 PDT 2014 by builder in /rel12.0/b1/R6/panos/main

    ___ ___ ___ ___
    /\ \ /\__\ /\ \ /\ \
    \:\ \ ___ /::| | /::\ \ /::\ \
    \:\ \ /\__\ /:|:| | /:/\:\ \ /:/\:\ \
    /::\ \ _\/__/ /:/|:|__|__ /:/ \:\ \ _\:\~\:\ \
    /:/\:\__\ /\__\ /:/ |::::\__\ /:/__/ \:\__\ /\ \:\ \:\__\
    /:/ \/__/ /:/ / \/__/~~/:/ / \:\ \ /:/ / \:\ \:\ \/__/
    /:/ / /:/ / /:/ / \:\ /:/ / \:\ \:\__\
    \/__/ \/__/ /:/ / \:\/:/ / \:\/:/ /
    /:/ / \::/ / \::/ /
    \/__/ \/__/ \/__/

    Running 32 bit architecture

    Initializing VMM
    Virtual address sharing is disabled
    platformVmRestrict: unsupported hypervisor: UNKNOWN (3)
    platformVmRestrict: unsupported apic mode (0)

    Time from clock is SAT JAN 24 13:43:31 2015 UTC
    Initial DNS resolving preference is ipv4-only

    Attempting to exec primary configuration file:
    'cf3:\config.cfg' ...
    Executed 0 lines in 0.0 seconds from file cf3:\config.cfg <<<<<< HERE!!!

    TiMOS-B-12.0.R6 both/i386 ALCATEL SR 7750 Copyright (c) 2000-2014 Alcatel-Lucent.
    All rights reserved. All use subject to applicable license agreements.
    Built on Tue Sep 30 11:10:17 PDT 2014 by builder in /rel12.0/b1/R6/panos/main

    Login: admin
    Password:

    This simulation software is the property of Alcatel. It may not
    be sold, leased, loaned or licensed to any non-Alcatel entity.
    A:vRR#
    A:vRR#
    A:vRR#
    A:vRR# show card

    ===============================================================================
    Card Summary
    ===============================================================================
    Slot Provisioned Type Admin Operational Comments
    Equipped Type (if different) State State
    -------------------------------------------------------------------------------
    1 (not provisioned) up unprovisioned
    iom3-xp-b
    A sfm4-12 up up/active
    B sfm4-12 up down/standby
    (not equipped)
    ===============================================================================
    A:vRR#

  4. Hi.
    Im not good with Linux at all.
    What directory do I need to be in to execute this command:
    $ /usr/local/bin/qemu-system-x86_64 -m 2048MB -enable-kvm sros-vm.qcow2 -serial telnet:localhost:3366,server,nowait -smp 2

    When I tried it, im getting error about incorrect ram. how can i fix that.
    Thank you.

  5. I am having exactly the same issue as JC above...
    Just configured 5 routers with OSPF (4 different areas) and had the configs disappear as soon as the devices rebooted... any ideas how to prevent this?

  6. Few questions if any one can help?

    1) To run a multi-vendor environment, lets say Cisco, Juniper and Alcatel together on a system, what is the best recommendation in terms of hardware that can support a network topology of 15 to 20 multi-vendor devices? Would the hardware resources be enough using desktop or best option is to setup a server to meet the processing and memory needs for this kind of topology?
    2) what about using Linux based system ?
    3) Can i configure Alcatel and juniper based QoS on these virtual devices and capture logs ?
    thanks a million for guiding me on this in advance.
    Aman

  7. I have tried but have not succeeded in getting two ALu routers to ping each other on port 2 (1/1/1). I have tried removing the link shutting down re-adding the link and restarting. Various switches, saving the project and nothing seems to work.

    Im running GNS3 on Yosemite on a Macbook pro.........Any ideas gratefully accepted.

    1. Hello There, I had the same experience, i suggest do the following:
      1) First setup the links (use port 1/1/1 or above, don’t use e0).
      2) Then run these devices and see if you can ping across.
      Thanks,
      Aman

      1. Hi Aman, I have setup the links and can't ping across. The result is:

        No route to destination. Address: 172.16.0.1, Router: Base

        Thanks

        Martin

        1. Hi Martin,
          I suggest delete the exiting TiMOS image in GNS3 and upload it again...
          Create a new topology with only two routers and setup a single link between them and then run both routers to see if you can run a ping....
          If it still doesn’t work, then I am sure your GNS setup might have issue somewhere else...
          I had the similar situation in the beginning, as I was using laptop with 8BG RAM and I could not setup two routes correctly even for ping.... i had to buy extra RAM before I was able to run ALU routers on GNS.... I maybe wrong, however, it is always good to check what is your cpu and memory utilization state when you run only two ALU routers...?
          As far as saving configuration on ALU devices is concern, you can't save configurations on these routers unless you have Alcatel's licensed TiMos. I have contacted Alcatel on several occasions during the last 4 months for trying to purchase licensed virtualized TiMOs firmware; however, they did not even bother replying me back! For saving a co0nfiguration, there are some work around solutions out there, however they are not very efficient and truly don’t work as they should!
          Thanks,
          Aman

  8. Hello everybody;
    Last week, I tried boot up this vm image without success. I had never seen a BIOS error using GNS3, when this error appears on screen, the startup process suddenly stop. Someone have any idea?

    Press any key to stop auto-boot...
    0
    auto-booting...

    SMBIOS table not found !
    ERROR: Failed to detect BIOS parameters

    boot device : ata=0,2
    unit number : 0
    processor number : 0
    host name : 0.0.0.0
    file name : cf3:/timos/boot.tim
    ftp password (pw) : *****
    flags (f) : 0x8
    target name (tn) : vRR
    startup script (s) : pl=1
    other (o) : sr12#niente_a_r2_6f,lava_r3|22|0

    Booting from ata=0,2:cf3:/timos/boot.tim
    Loading cf3:/timos/boot.tim ...
    Version L-12.0.R6, Tue Sep 30 11:09:39 PDT 2014 by builder in /rel12.0/b1/R6/panos/main
    text:(1649920-->3819948) + data:(120896-->522452)
    Starting at 0x18000000...

    loApic version = 0x%8.8x
    loApic max_lvt = 0x%8.8x
    (s) boot params: pl=1; setting TgtPf to 0x00000001
    BIOS MP Floating Pointer structure corrupt (0xf25d0) - chksum 0xf9 (expect 0)
    loApic version = 0x00000011
    loApic max_lvt = 0x00000005

    ACPI: ctrl-x only supported with PXE boot. (version >= 3)
    ACPI: _S5_ error: SLP_TYPa does not contain values between 0x00 and 0x07 (it is 0x0)
    ACPI: Not enabled.
    SMBIOS table not found !
    ERROR: Failed to detect BIOS parameters
    SMBIOS table not found !
    ERROR: Failed to detect BIOS parameters

    Running in a UNKNOWN virtual machine

    Total Memory: 1536MB Chassis Type: sr12 Core Freq: 2000.087 MHz
    TiMOS-L-12.0.R6 boot/i386 ALCATEL SR 7750 Copyright (c) 2000-2014 Alcatel-Lucent.
    All rights reserved. All use subject to applicable license agreements.
    Built on Tue Sep 30 11:09:39 PDT 2014 by builder in /rel12.0/b1/R6/panos/main

    TiMOS BOOT LOADER
    platformVmRestrict: unsupported hypervisor: UNKNOWN (3)
    platformVmRestrict: unsupported apic mode (0)

    Time from clock is THU AUG 06 04:17:34 2015 UTC

  9. I Love Alcatel it´s wonderfullllll, Brezular you are the best ahahahahah.
    Since i get in this world always i´m looking for to something to give a answer on Alcatel virtualization (PBX) OXO and OXE... Thanks

  10. Hi, I am trying setup my SROS on GNS3, I already install the QEMU VM, and its working fine, (It boot, and I can open the console, and configure the machine) , but, when I connected a link between the TiMO and some Router and then turn on the QEMU VM (TiMO), it does not able to connect to the console (just open the console and then close almost immediately).

    I am using Linux Mint 17 on my host machine. and this is the QEMU Configuration:
    4096 MB
    quemu-system-x86_64
    -nographic

    Thanks in advance

    1. Hi, I am having issues with my QEMU, please what version of GNS3 are you using? From my end GNS3 2.1.3 is not helping me.

  11. Hi,
    How can I use qemu (which options) from a headless machine to which I connected to by SSH.
    I want to use qemu monitor functionality and the devices console ports (Cisco, ALU, Core Linux)

    I tried out nographic, curses, tcp:: mon:stdio and they didn't work well. :-(
    I don't want VNC, too, because keyboard problems and password in qemu monitor mode.

    TIA,

  12. Dear freinds, please your helps. i tried with all versions of GNS3 to ping between two alcatel routers after configuration done but i could not succeed to ping them. im working on it since 5 weeks now but till now i cannot ping them

    1. I was curious if the new GNS3 1.5.4 and TiMOS-B-13.0.R4 are working together. I tested connectivity with ping command between interfaces of vSIM and Core Linux with success. I only needed to copy & paste commands from tutorial.

  13. How to map the interface to the GNS?
    Why I see e0 & e1 port on GNS but from cli they are 1/1/1 – 5?
    e1 is 1/1/1, e2 is 1/1/2?
    How to connect to another device?

    Thank you very much.

  14. Hi,can you help me ?i use GNS3,it always happen this problem.How to sovle?
    Watchdog: Task 0x1f84c48c (sshKeyGenTask) suspended for 500 ticks.
    can only run one tt() at a time

    Watchdog: Task 0x20054404 (sysMonitor) blocked for 115 ticks.
    can only run one tt() at a time
    *** Blocked task info during crash dump - ending ***

    Rebooting...

  15. Can anybody please share me the link to download alcatel 7750 image please .
    1.TiMOS-SR-13.0.R4-vm.qcow2
    2.TiMOS-SR-12.0.R6-vm.qcow2
    3.TiMOS-SR-12.0.R18.qcow2
    Any of these above..
    thanks a ton in advance

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.