Testing 802.1Q and Multicast Traffic between the Cisco CSR 1000v and the Cisco 3725 Router

In a previous tutorial we explained how to connect Cisco CSR 1000v running on VMware player to the Cisco Multiservice access router 3725 emulated by Dynamips and running inside GNS3. We will use the same network topology in order to test if the multicast traffic and 802.1Q tagged traffic is transferred correctly between the routers.

network_topology

Picture 1 - Network Topology

The Cisco 3725 Router Configuration

The Cisco 3725 switchport FastEthernet 1/0 is configured as a trunk port with all VLAN traffic allowed via the trunk port. The virtual switchport interface SVI VLAN 10 is created on the the router and configured with the IP address 192.168.10.1/24. The virtual interface loopback 0 is configured with the IP address 192.168.1.1/32.

In order to test transfer of the multicast traffic between the routers, the OSPF routing protocol is configured on the router. OSPF configuration matches the subnets configured on the interface loopback 0 and FastEthernet 1/0.

Left click on the Cisco 3725 router and select Start option from the menu. When the router boots up, make following changes in its configuration.

1. Configure the router hostname
Router>enable
Router#configure terminal
Router(config)#hostname c3725

2. Create VLAN 10
c3725(config)#vlan 10
c3725(config-vlan)#name TEST
c3725(config-vlan)#exit

3. Configure the trunk port
c3725(config)#interface fastEthernet 1/0
c3725(config-if)#switchport
c3725(config-if)#switchport mode trunk
c3725(config-if)#switchport trunk encapsulation dot1q
c3725(config-if)#no shutdown
c3725(config-if)#exit

4.  Assign an IP address to the switch virtual interface SVI
c3725(config)#interface vlan 10
c3725(config-if)#ip address 192.168.10.1 255.255.255.0
c3725(config-if)#exit

5. Assign an IP address to the interface loopback 0
c3725(config)#interface loopback 0
c3725(config-if)#ip address 192.168.1.1 255.255.255.255
c3725(config-if)#exit

6. Configure the OSPF routing protocol for interfaces loopback 0 and FastEThernet 1/0
c3725(config)#router ospf 10
c3725(config-router)#network 192.168.10.1 0.0.0.255 area 0
c3725(config-router)#network 192.168.1.1 0.0.0.0 area 0
c3725(config-router)#do write

The Cisco CSR 1000v Router Configuration

Run VMware player and start Virtual machine. When the router boots up, make required changes in its configuration.

1. Configure the hostname
Router>enable
Router#configure terminal
Router(config)#hostname CSR_1000v

2. Bring the interface GigabitEthernet 0 up and let it to obtain an IP address from the DHCP server

CSR_1000v(config)#interface GigabitEthernet 0
CSR_1000v(config)#no shutdown
CSR_1000v(config)#exit

At this point the interface GigabitEthernet 0 should obtain an IP address from DHCP server that is running on TP-link router. The interface GigabitEthernet 0 is internally connected with the VMware interface vmnet0. The interface vmnet0 was previously configured as Bridge  in order to be bridged to with the interface Ethernet p3p1. The bridged connection allows CSR 1000v to receive an IP address configuration from the DHCP server.

Check if the interface GigabitEthernet0 obtained the IP address from the DHCP server.

picture23

Picture 2 - IP Address 192.168.0.100 obtained from the DHCP Server running on TP-Link Router

If it is required to manage the Cisco CSR 1000v router outside of the Local Area network, we must configure a static default route. The static default route sends a traffic to networks that are not presented in the routing table to the default gateway IP address. In our network it is the IP address 192.168.0.1 that is configured on the LAN interface of the TP-link router.

The interface GigabitEthernet 0 is assigned to the VPN routing and forwarding instance VFR named Mgmt-intf.

picture24

Picture 3 - Management Interface GigabitEthernet0  in VRF  Mgmt-intf 

3. Configure the default static route

CSR_1000v(config)#ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 192.168.0.1

Check if the default static route is presented in the routing table Mgmt-intf.

picture25

Picture 4 - f Routing Table VRF Mgmt-int

In order to test if the default static route is working,  ping the Google IP public address 4.2.2.2.

picture26

Picture 5 - Pinging the Google IP address

4. Enable Cisco Discovery Protocol CDP globally and for the interface GigabitEthernet 1

To test the layer 2 connectivity, enable CDP protocol for the interface GigabitEthernet 1.

CSR_1000v(config)#cdp run
CSR_1000v(config)#interface GigabitEthernet 1
CSR_1000v(config-if)#no shutdown
CSR_1000v(config-if)#cdp enable

picture27

Picture 6 - Cisco 3725 Router is presented In the list of the CDP Neighbours

The Cisco router 3725 is presented in the output of the show cdp neighbors command. We have proved that L2 connection is working between the Cisco CSR 1000v and the 3725 router.

5. Configure the L3 subinterface on the interface GigabitEthernet 1

CSR_1000v#configure terminal
CSR_1000v(config)#interface GigabitEthernet 1.10
CSR_1000v(config-subif)#encapsulation dot1q 10
CSR_1000v(config-subif)#ip address 192.168.10.2 255.255.255.0
CSR_1000v(config-subif)#no shutdown
CSR_1000v(config-subif)#exit

If the Layer 3 connectivity is working between the Cisco router CSR 1000v and 3725 we must be able to ping the IP address 192.168.10.1. This IP address is configured on the VLAN 10 interface of the Cisco 3725 router.

picture28

Picture 7 - Pinging the IP address 192.168.10.1

With successfully pinging the IP address 192.168.10.1 we have proved that tagged packets with 802.1Q VLAN header are transferred between the routers.

6. Assign the IP address to the interface loopback 0

CSR_1000v(config)#interface loopback 0
CSR_1000v(config-if)#ip address 192.168.1.1 255.255.255.255
CSR_1000v(config-if)#exit

7. Configure the OSPF routing protocol for the interfaces loopback 0 and GigabitEthernet 1

CSR_1000v(config)#router ospf 10
CSR_1000v(config-router)#network 192.168.10.1 0.0.0.255 area 0
CSR_1000v(config-router)#network 192.168.1.2 0.0.0.0 area 0
CSR_1000v(config-router)#do write
CSR_1000v(config-router)#^Z

8. Check of the OSPF routing protocol is working between the Cisco CSR 1000v and 3725 routers

Examine the routing table of the Cisco CSR 1000v router. Check if the route 192.168.1.1/32 is presented int he routing table.

picture29

Picture 8 - Routing Table of CSR 1000v router

Turn on debug of OSPF hello message. Check if the multicast OSPF hello messagess are sent and received via interface GigabitEthernet 1.10.

CSR_1000v#debug ip ospf hello

picture30

Picture 9 -  OSPF Protocol Hello messagess are sent to multicast IP address 224.0.0.5

Finally, ping the IP address 192.168.1.1 configured on the loopback interface of the router 3725. 

picture31

Picture 10 - Pinging the IP address 192.168.1.1

As ping is working L3 connectivity is achieved between the routers.

6 thoughts on “Testing 802.1Q and Multicast Traffic between the Cisco CSR 1000v and the Cisco 3725 Router

  1. Brezular,
    I really enjoy your articles on networking and this is great on the CSR 1000v. I was wondering if you could write articles on the Nexus 1000V and the ASA 1000V and how they could be interfaced to GNS3? Keep up the good work...

  2. Hi,

    Nice article...thanks! I am currently fiddling with CSR and facing a weird problem which I would like to share with you. I have installed CSR on workstation 8.0 with 2 Gig interfaces connected with vNIC vmnet-3 and vmnet-4. I am trying to implement a very simple topology with two 7206 connected with two Gig interfaces of CSR i.e. the topology is 7206----CSR----7206. Even after configuring correctly with the right IP addresses, I am not able to ping the second 7206 from the first one through CSR, though I am able to ping the respective gateways on CSRs Gig interfaces. I strongly believe this has nothing to do with CSR and has to do with VMWARE vmnet settings....have you faced the same problem ever? what is the solution?

    Thanks in advance...

    1. Oh btw, missed that completely....the 7206 are routers from GNS3 which are connected to VMWARE using vmnet adapters using cloud...checked everything else is perfectly OK(no config issue) except the fact that no traffic passing through CSR...

  3. Hi Brezular,

    Thank you for your work in setting up and demonstrating how to get the csr 1000v working. I used your other article to get it set up on vmware workstation and player too.

    I seem to have the same problem as the commenter CSR; I can't get a connection from (GNS3/dynamips) to the cisco csr 1000v on vmware when using vmnet8.

    Any router connects in gns3 via cloud to vmnet1 but not vmnet 8 and I can't seem to find anyone that has managed to get them connected and pinging in that configuration.

    Any advice or pointers in the right direction would be really appreciated.

    Best regards,

    Tom

    1. Hi Tom,
      unfortunately I cannot check your issue as I do not use VMplayer anymore. But you try these troubleshooting steps to check if problem is connected with GNS3 related or with VMplayer:
      1) check if network adapters 2 and 3 are switched to Host-only mode.
      2) if they are switched to host only-mode, do following:
      a) delete all vmnet interfaces except the network adapter 3 - interface vmnet8
      a) assign an IP address 192.168.1.1/24 to vmnet8 from your host. Then start CSR and configure the IP address 192.168.1.2/24 for interface GigabitEthernet0 (only interface GigabitEthernet0 is presented in CSR, right?). Ping IP 192.168.1.1 from CSR. Is it ping successful?
      3) If you can ping vmnet8 - IP 192.168.1.1/24 from CSR, then problem is connected with GNS3.

Leave a Reply to Tom Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.